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Abstract

This third lab is concerned with operational amplifier (OpAmp) com-
pensation, both in CMOS simulation and on a real physical circuit. The
somewhat abstract concept of ’stability’ shall be illustrated in particular
with the physical circuit.

It is the last in a series of three lab tasks that will be graded and
will count 40% towards the final grade. The deadline is November 25th,
14:15! It is a hard deadline! Do not miss it! Plan to submit well ahead
of the deadline! Submissions shall be made by e-mail to the lecturer:
hafliger@ifi.uio.no!

1 Graded Mandatory Group Assignments

Note that this is part of the courses exam and strict rules apply as described in
the document http://www.mn.uio.no/ifi/english/studies/admin/mandatory-assignments/
index.html. The page explains the significance of mandatory assignments in a
course and in particular group assignments. It also specifies your responsibility
to not plagiarise anybody else’s work and that you are required to conduct and
understand your own experiments and obtain your own results, while you are
still allowed and encouraged to exchange advice and experiences also between
groups.

Each group must deliver a written lab report by email to the lecturer before
the deadline and the lab assignment will be graded as A,B,C,D,E or F. Together
with the previous mandatory lab exercise 2 this grade will cont 40% towards
your final grade (in other words lab 2 and lab 3 will count 20% each)

Each question is graded indicating the weight when grading.
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2 About Writting a Lab Report

You are required to execute the tasks and answer all the questions posed below
and to submit a report on your work. The report needs to be explaining clearly
what you have done, how you have done it, what the results were and what you
conclude from them. Make sure to answer all questions! Supply the report with
drawings of the circuits (including the values of the components and parameters
you used where appropriate, e.g. bias voltages/currents, component sizes etc.)
and measurement setups, and show your measurements in graphs! Use labels
in the schematics that you draw, such as M1, M2 (M is often used fro labelling
CMOS transistors), opamp1, I1, V1 etc. You should then use those labels in
your text, since it is much easier to write: ’transistor M1 in figure 1’ than ’the
transistor third from the top and second from the left in the righthand side
circuit in figure 1’. Include a photograph of your PCB into the report!

3 Tools

• Soldering Iron and Generic Printed Circuit Board (PCB)

To make it easy for you to work on your project from lab session to lab
session and to give you some hands-on experience with soldering you’ll get
your own PCB from the lab assistant and you will solder your components
onto that board permanently. Get instructions from the lab assistant first
before you try for the first time! A hint: the solder iron should touch and
warm up both the copper on the PCB and the pin that you want to solder
to it. Then touch the pin with the solder (i.e. not the solder iron directly)
until the pin is hot enough to make the solder melt and flow down to the
copper surface of the PCB. You’ll get a good connection only when you
see the solder “flow out” onto the copper.

Plan your layout of componants and cables on the PCB before you start
soldering and try to make things compact and organized.

• MATLAB
We will be using MATLAB for all excersises and you should bring a
working knowledge to this course. If you have none, get a crash course
from a fellow student who has used it! It is a powerful mathematics
tool with a command line interface. One useful function is ‘help’. ‘help
<command name>’ will display an explanation on how to use ‘<com-
mand name>’. Another help function that helps you find functions that
you do not know the exact name of is ‘lookfor’. Type ‘help lookfor’ to
learn more.

• Cadence, “Analog Environment” simulation tool
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Startup: in this exercise you’ll use a professional ASIC layout tool to
conduct a simulation of a simple circuit with a high level of detail, much
more detail than the simple models used in the course book. The program
runs under Linux and it will be set up to simulate circuits implemented
in a 0.35µm technology. In order to use Cadence you’ll have to make a
working directory, named for example “ams035”. Follow the instructions
on http://nano.wiki.ifi.uio.no/Oppstart AMS 0.35um to start Cadence. In
the main window (icfb window) choose “tools→library manager” and the
library manager will pop up. In the left hand side column you’ll see a list
of libraries.

Creating your work library (which you have probably already done for
lab 1): in the editable field on top of that list, enter a new library name
for your working library in which you will create your cell containing the
schematic to simulate. Compose the name of your initials first followed
by the technology identifier “AMS035” and then a name of your choice,
all seperated by underscores, so in case of the lecturer the library is called
“PH AMS035 INF3410”. (This naming convention is not terribly impor-
tant for this exercise, but should you start a master project with NANO
and collaborate on a layout where different people share their libraries this
will be convenient.) After having written the name, hit “return”. You wil
first be asked to confirm the name. Hit “ok”. Then there will be a pop-up
asking for a “technology file”. Tick off “attach to an existing techfile” and
hit “ok”. In the next pop-up select the file “TECH C35B4” and hit “ok”.

**NEW*** Referenceing a different external library: A schematic is avail-
able as a starting point for this exercise in a library created by the lecturer.
To make it visible you’ll have to specify the path to this library. In the
library manager from the menue bar choose: “Edit→Library Path ...”
and you’ll get a pop-up window called “Library Path Editor”. In the
“library” column write: “PH AMS35 LAB3”, and in the path column:
“/hom/hafliger/ams35/PH AMS35 LAB3”. From the menu bar choose
“File→Save” or “File→Save As...” (the latter with the standard choice
“cds.lib” for a name and “OK” when asked to overwrite). You should now
see the library “PH AMS35 LAB3” in your library manager with the cell:
“basic opamp”, which is the two stage opamp described in chapter 6 in
the book. You will want to copy it entirely into your own library in order
to be able to edit it. You can do that in the library manager by selecting
the cell and choosing “Edit→Copy”.

Creating a schematic: Actually for this exercise you might not want to
create a blank schematic as for lab 1 but you may simply want to copy the
cell from the lecturers library and start editing it. You might want to give
it a new name, like “lab3 task4” or similar. You might want to keep a copy
of each partial solution so when finished with a task you might not want to
continue editing the cell but make another copy instesd, e.g. “lab3 task5”.
However, if you want to start with a blank schematic: Select your new
library on the left. Create a new cell by writing a name in the editable
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field on top of the second column, e.g. “lab3”, and hit “return”. A pop-
up will ask you for a view name, which should be “schematic” and a tool
which should be “composer-schematic”. If that is set correctly hit “ok”.
(Cells can have different views, typically a “schematic” that describes the
cell on that level, and a “layout” containing the layout that corresponds
to that schematic, and also a “symbol” that you can use hierarchically in
other schematics to represent this circuit with a simple symbol, but this
need not concern you here and now.)

Editing a schematic: Open the cell by double clicking the cell-view “schematic”
(or if you have just created a new cell a blank schematic editor will pop-
up, to which you can add a number of circuit “instances” that you’ll need
to run your simulation.) To add instances select “add→instance...” from
the top tool-bar. A pop-up will ask you which instance of a cell and cell
view to add. Usually you will only instantiate “symbol” cell views into a
schematic. The cells you are going to use for this exercise are to be found
in two libraries: “PRIMLIB” and “analogLib”. “PRIMLIB” contains the
transistors, cell names “nmos4” and “pmos4”. “analogLib” contains the
symbols for the global power nodes “vdd” and “gnd”, as well as a dc volt-
age source (“vdc”) and a bit more dynamic voltage signal source (“vpulse”
that allows you to provide pulses and ramps) for simulation purposes (cor-
responding current sources are “idc” and “ipulse”). With these elements,
you can now draw the circuit you want to simulate. If you select a compo-
nent in your schematics and hit the key “Q” you’ll get a list of parameters
for this instance of a cell. In this pop-up window you can for instance
set W and L of transistors, set the “DC voltage” for “vdc” and define
the behaviour of the output of “vpulse”. Note that “vdd” is but a global
electrical node and not a power supply by itself: you will always have to
place a “vdc” between an instance of “vdd” and “gnd” and set its “DC
voltage” to 3.3V (for this 0.35µm technology) for the simulation to run
correctly. You can draw connections by selecting “Wire(narrow)” from the
left hand side tool bar. you can name wires/electrical nodes by selecting
“Wire Name” from the tool bar. Naming wires is quite useful to identify
electrical nodes easily in the simulation output.

Transient simulation: To run a simulation choose “tools→Analog Environ-
ment” from the drop-down menu bar of the schematics editor. A new pop-
up window will allow you to define simulation parameters and run a simu-
lation. In its drop-down menu bar select “outputs→to be plotted→Select
on schematic”, and select the nodes that you want to see the voltages or
currents of. By clicking on a cable you’ll select a voltage to be displayed,
by clicking on a pin of a component you’ll select the current coming out
of that node. Click “choose analyses” in the right hand tool bar, and then
select “tran” in the pop-up. Set the stop time to an appropriate value:
this will depend on how you set up your signal sources for the simula-
tion (e.g. “vpulse”). Always select “Design→Check and Save (X)” in the
schematics editor before finally running a simulation. If you have edited
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your schematics and have not saved it, the simulation will fail to run. To
run the simulation select “run” in the “analog environment” right hand
tool bar (the green traffic light).

***NEW*** AC simulation/Bode plots: As above but under “choose anal-
yses” tick off “AC”. This will perform something very similar to a small
signal simulation creating magnitude and phase plots of the chosen output
signals. (The difference is that all DC levels will also occur in the output
plots.) You’ll be asked to specify a frequency range: choose “1” to “1G”
(1Hz to one GHz) for this exercise. You will also need to set up your volt-
age and/or current sources for the AC analysis: they will have parameters
“AC magnitude” and “AC phase” and “DC voltage”. Usually if you just
have one test voltage/current the AC magnitude is 1 (an arbitrary unit
that sets the relation of the test signal to the magnitude plot). All other
sources should have a blank “AC magnitude”, i.e. they will only provide
bias voltages/currents, that is to say they will provide the voltage/current
specified under “DC voltage/current”. “AC phase” is also just relevant if
two inputs shall be simulated with different phase relative to each other
(e.g. a differential input where one is at phase 0o and the other 180o). In
the graph window you will get a magnitude plot over the frequency range,
but unfortunately the y-axis will not be logarithmic but linear. If you
select a particular curve by clicking on it, you’ll get a drop down menu
on the upper right that lets you choose “Phase” or “Magnitude” to be
displayed.

There are several ways to export data from the simulation results to MAT-
LAB. One is to copy the following command into the main (icfb) window:

ocnPrint(v("/out" ?result ’ac) ?numberNotation ’none ?output "out.m" )

This will create a file “out.m” in your cadence working directory containing
the voltage of node “out” of your simulation as a two column matrix
where the first column is the time and the second is the voltage as a
complex number “complex(a,b)” (a function that matlab understands and
interprets as a+bj). To actually load this into MATLAB you’ll have to
edit the file: remove all the text at the start until the actual matrix starts,
insert a “m=[” at the start of the matrix and a “];” at the end of the
matrix. (You may use another variable name but “m” if you like.) Now if
you runn MATLAB in your CADENCE working directory you can simply
write “out()” and the variable m will contain your matrix.

• GPIB interface

GPIB is a bus system that allows your computer (MATLAB) to control
lab equipment automatically and to transfer data from or to the various
devices. To make matlab work with the GPIB interface you must first
follow the steps on the following webpage:
http://nano.wiki.ifi.uio.no/GPIB
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Sometimes the GPIB system fails. If this happens you may have to restart
MATLAB and switch off and on the Lab equipment before continuing.

• Oscilloscope HP54622D
A manual can be found in the lab. DO NOT REMOVE IT! Only consult
it in the lab. Traces can be loaded to the computer via the GPIB interface
in Matlab. Again: make sure that you have followed all the steps on http:
//nano.wiki.ifi.uio.no/GPIB before attempting to use the GPIB interface
functions in matlab. Then try:

>> % Get traces from the oscilloscope:
>> [time,chan] = HP54622_GetData2;
>> % Plot the results:
>> plot(time,chan(1,:),’g’,time,chan(2,:),’r’);
>> xlabel(’Time [s]’); ylabel(’Voltage [V]’);

This should plot the trace from channel 1 in green and channel 2 in red.
Please note that both channels on the oscilloscope must be turned on for
this script to work. You may use the Run/Stop and Single buttons to find
a suitable trace for dumping.

• An Agilent 33250A wave form generator
Its use is quite intuitive. When you have set a waveform type, a frequency,
offset, and amplitude, you also need to activate the ‘output’. For GBIB
control (that you will need for this exercise) talk to the lab assistent!

• Voltage sources
A GPIB controlled voltage source is the ‘Agilent E3631’. You may use the
E3631 as both a power supply and to set a constant input voltage. It is
preferable to use the +25V Channel to set the power supply voltage, and
the 6V channel to set an input voltage because it has a finer resolution.

Example session to initialize GPIB interface to HPE3631 and set its output
voltage through MATLAB:

>> HPE3631_Init;
>> HPE3631_SetILimit(1,0.1);
>> HPE3631_SetVolt(1,1);
>> HPE3631_Operate;

This should set the HPE3631 6V channel to 1 Volts. The HPE3631_SetILimit()
command sets a current limit of 0.1 Ampere.

• Multimeters
Keithley 6512/617 and Agilent 34401A are a multi-meters that you can use
tomeasure currents and voltages, and also to verify that constant voltages
are where they are supposed to be. Remember to turn off the “zero check”
on the Keithley before use.
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Figure 1: First order RC filter

• CMOS transistors
The IC that contains a set of individual transistors is labeled ’MC14007UBCP’.
A data sheet will be available in the lab or through the course pages that
shows which pins are to be used as bulk, source, drain, and gate.

• Capacitors
there are only ceramic cpacitors provided in the lab and you are only
allowed to use those! The reason is that one needs to be very cautious when
using tantal capacitors! They can only used with the right polarity. A
huge negative voltage over a tantal capacitor can even burst the capacitor
physically and endanger eyes and skin of people nearby. If you need to
have both negative and positive voltages across a capacitor they cannot
be used.

• Potentiometer operated as tweakable voltage source
If the Keithley or the HP is to cumbersome to use as a voltage source
you may also just use potentiometers as resistive voltage dividers between
Vdd and Gnd.

Always clean up the lab after your time slot, such that the next group can
use the equipment!

4 Prelab

You will need to control the waveform generator in matlab to provide sinu-
soidal output signals over a wide range of frequencies with equal spacing on a
logarithmic scale.

Task 1 (4p): Write a MATLAB script that uses the waveform generator via
the GPIB interface to generate a frequency sweep from 100Hz to 1MHz
of 1-2V sinusoidal waveforms and measures the gain and phase shift of a
circuit for each of those frequencies from the oscilloscope. Sample at least
5 frequencies per decade. The script shall plot the result as a Magnitude
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plot. Test and demonstrate the script with a simple RC-filter as shown in
figure 1.

Hints: You will need to adapt the time window of the oscilloscope through
the GPIB interface as you sweep through the frequencies to get a good
phase measurements. To measure phase, trigger the oscilloscope with the
input signal to your circuit. The oscilloscope can measure both amplitude
and phase of a signal directly when sending the correct GPIB request.

5 Compensation in Simulation

Task 2 (1p): Perform an AC simulation of the “basic opamp” cell as described
in section 3, export the magnitude and phase of the output signal to
matlab and make a Bode-plot with dB on the y-axis and log ω on the
x-axis.

We will now perform a lead compensation for this amplifier in a follower
configuration (i.e. β = 1) as descriped in the book chapter 6, page 258. So do
not connect the follower feedback loop but work with the open loop gain: since
β = 1 the open loop gain is the loop gain.

Task 3 (4p): Now follow the steps 1-4 (do not bother with steps 5 and 6)
for lead compensation descriped in the book. For step 1, do not try
to determine gm7 but connect the 2pF compensation capacitor that is
already in the schematic instead as the starting point. Do not go through
several iterations of steps 3 or 4, but see how good the result will become
with a single pass. Document each step and intermediate results! It is
recommended to copy the schematic to a new cell for each step, such that
you can go back to an earlier step without problems.

Task 4 (2p): Finally connect your final result as a follower. Make a Bode-plot
of the follower and plot it together with the open loop gain Bode-plot.
What are the loop unity gain frequency and the phase margin? Indicate
them in the plot.

6 Opamp Dynamics on a Physical Circuit

We will refine our transconductance amplifier from lab 2 and build a classic
2-stage amplifier also physically. An additional output stage will increase the
overall gain, but may also introduce some stability problems. Other typical
amplifier features like offset, slew-rate and unit-gain bandwidth will be treated.

As shown in Figure 2 we have combined a differential pair as input stage
and a common-source output stage. Please note the decoupling capacitors on
the rails avoiding rail-induced noise. (They can be coupled to either VDD or
VSS) In Figure 2 we have also indicated a compensation capacitor, CC , we are
going to introduce later. The 150kΩ resistor is used for biasing both the tail
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Figure 2: Two stage operational amplifier

Figure 3: Follower

current of the input stage and the common-source output stage. VSS shall be
0V and VDD 10V.

Task 5 (2p): Since all transistors are the same size, there should be a system-
atic offset as described in the book chapter 6. For a zero input difference
(both inputs are at the same voltage close to the middle beteen VSS and
VDD), what is the output voltage? What input difference do you need to
provide in order for the output to be roughly at (VDD-VSS)/2?

Now we will explore this amplifier with maximum negative feedback in a
configuration known as voltage follower (Figure 3). We will now explore the
compensation capacitor effect.

Task 6 (4p): Wire up the schematics shown in Figure 4. Apply a suitable si-
nusoidal (something like 2V@100Hz). Adjust your oscilloscope to capture
in MATLAB a time-domain trace of the output voltage. Then add the
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Figure 4: Resistive divider feedback amplifier

compensation capacitor CC = 0.1nF and make another MATLAB cap-
ture. Plot both traces together and explain the difference. What is the
purpose of the compensation capacitor?

For all further experiments, leave the compensation capacitor in place!

Task 7 (2p): In the follower configuration, when the input is at (VDD-VSS)/2,
is there a difference/offset to the output? How big is that offset?

Next, we will determine the slew-rate limitation of the amplifier. We apply
a large transition on the input and measure the quality of the output signal.

Task 8 (3p): Apply square waves with different amplitudes from small to large
swing (±4V?) at 100Hz. Try to obtain both, amplitudes that are subjected
to slew rate limitation and amplitudes that are not. Plot them on top of
each other. At least for the largest amplitude you should see the slew
rate in the initial slope of the output transition. Determine the slew-rate
limitation of both the positive going and negative going transition. What
feature of the plot does actually indicate that you are indeed limited by
slew rate? Which of the amplitudes indicate to be subject to slew rate
limitation and which ones do not?

Task 9 (3p): Apply a ±50mV sinusoidal to the input of the voltage follower
avoiding large signal slew-rate limitations. Sweep the input frequency to
find the maximum frequency performance of the amplifier. In MATLAB
make a Bode-plot of both magnitude and phase characteristics of the fol-
lower. What is the bandwidth of the amplifier? What is its approximate
unity loop gain frequency ωt (Hint: figure 5.2/5.6 in the book.) and phase
margin?

As illustrated in Figure 4 we may change the feedback of the amplifier by
feeding back a fraction of the output signal. Based on simple analytical models,
we may approximate the closed loop gain of the amplifier.

Task 10 (1p): What is the expected closed loop gain at DC of the amplifier
in Figure 4?
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Task 11 (2p): Apply a small input signal avoiding clipping and slew-rate lim-
itations to the configuration shown in Figure 4. In MATLAB make a
Bode-plot of both phase and gain and determine the corner frequency of
this configuration. What is the bandwidth now? What is the approximate
unity loop gain frequency, ωt, and the phase margin of the amplifier.

Task 12 (3p): A common measure of amplifier performance is called Gain-
Bandwidth product (GBW). Determine the GBW in our previous two
measurements (follower and 11-times amplifier). Explain why this is an
interesting amplifier parameter.
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